Links Checks

All links are within document folder

Links Checks
This check looks at the location of links on your computer and flags up if they are NOT contained within the same folder as the InDesign document.

‘Links’ are made to the original files of images that have been placed into the InDesign document; they might also, less commonly, be text files.

InDesign can cope with links from anywhere on your computer; for example, your Desktop, your Dropbox or Google Drives, or on remote file servers, and this approach is fine while the document is in progress. However, once the document is ready for output, you should gather together all links items into a single folder within the same folder as the InDesign document, otherwise images will almost certainly become unlinked or get lost, preventing reuse in the future.

  • Good InDesign housekeeping means always knowing where your linked files are!
GreenLight’s dialog listing linked images not present in same folder as InDesign

You can fix the problem above by moving the linked files and choosing to relink in InDesign’s Links panel menu.

The Relink command from InDesign’s Links panel menu

Alternatively, it is possible to Package a document (File menu > Package…). This brings together copies of all linked items in a 'Links' folder together with a copy of the InDesign document into a new folder with the document’s name. You can also choose whether to create a PDF and IDML file, (which can be opened by previous versions of InDesign).

Adobe links and embedded graphics help

Read full article
Links Checks

Links are embedded

Links Checks
This check make sure links HAVE been embedded in InDesign.

‘Links’ are made to the original files of images that have been placed into the InDesign document; they might also, less commonly, be text files.

External links can instead be saved inside the InDesign document through ‘embedding’. An icon

is shown under the Status column in the Links panel (InDesign Window menu > Links)

InDesign’s Links panel showing embedded images in its Status column

Advantages of embedding links:

  • Links travel with the document and can’t go missing if renamed, moved or disconnected.

Disadvantages of embedding links:

  • Difficult to change and update the links.
  • Potential for massive increase of the InDesign file’s size as each image is saved inside the file.

To embed an image, select its name in the Links panel, and from the panel menu choose Embed Link.

Embedding an image using InDesign’s Links panel menu and Embed Link command
  • Embedded images can also be unembedded to revert to linked imaged if required through the same panel menu.

Adobe links and embedded graphics help

‍

Read full article
Links Checks

Links are not embedded

Links Checks
This check make sure links have NOT been embedded in InDesign.

InDesign's default method for working with images is that ‘links’ are made to the original files that have been placed into the document. Less commonly, this might also apply to text files.

External links can instead be saved inside the InDesign document through ‘embedding’. An icon

is shown under the Status column in the Links panel (InDesign Window menu > Links)

InDesign’s Links panel showing embedded images in its Status column

Advantages of embedding links:

  • Links travel with the document and can’t go missing if renamed, moved or disconnected.

Disadvantages of embedding links:

  • Difficult to change and update the links.
  • Potential for massive increase of the InDesign file’s size as each image is saved inside the file.

Fix the problem of changing an embedded image into a linked image by selecting its name in the InDesign Links panel and from the panel menu choosing Umembed Link.

Embedding an image using InDesign’s Links panel menu and Embed Link command

You can then choose whether to link back to the original file or create a new copy to link to instead

InDesign's dialog when unembedding an image with the Links panel

Adobe links and embedded graphics help

‍

Read full article
Links Checks

Links are present and up to date

Links Checks
This check make sure all InDesign links are OK. No image links can be missing or modified.

‘Links’ are made to the original files of images that have been placed into the InDesign document; they might also, less commonly, be text files.

Icons are shown under the Status column in the Links Panel. (InDesign Window menu > Links) to indicate a problem.

= Missing Link

Links can go missing if renamed, moved or your computer is disconnected from them if held remotely e.g. on a file server.

= Modified Link

Links become modified if edited outside of InDesign e.g. resized or colour adjusted in Photoshop.

Fix this problem by selecting the link(s) in InDesign's Links panel and from the panel menu choosing Update in the case of a Modified image or Relink if missing.

Relinking to a missing image in InDesign using the Links panel

Adobe links and embedded graphics help

‍

Read full article
Links Checks

No RGB links

Links Checks
Checking solely for linked RGB images. RGB objects and text are allowed.

The RGB (Red, Green, Blue) colour space in intended for screen representation of colour and can be applied to pixel images, vector images, InDesign objects and text.

When RGB is to be used in commercial printing it is typically converted to the ink colours CMYK (Cyan, Magenta, Yellow and Black) either before placing or on export.

The actual colour that RGB or CMYK describes depends on many variables such as the type and setup of screen when viewing RGB and the ink, paper and light source used when viewing CMYK.

Unless working in a colour managed workflow the conversion from RGB to CMYK can cause unexpected and disappointing results. To prevent this, one approach is to ensure all images are generated or converted to CMYK in the same way before they reach the InDesign page.

This GreenLight check will support this workflow method by flagging placed image that uses RGB.

GreenLight's dialog warning of the presence of an RGB image

Fix this problem by using CMYK images in InDesign.

Viewing Colour Spaces in the InDesign Links panel

It is possible to add a Colour Space column to the Links Panel:‍

  1. Choose the InDesign Links panel (InDesign Window menu > Links)
  2. Choose Links Panel menu > Panel Options…
The Panel Options dialog is accessed from the Links panel menu
  1. Click the checkbox for Colour Space under the Show Column heading
The Colour Space checkbox in the Panel Options dialog selected
  1. Click OK
    In the Links panel a new column appears indicating the Colour Space of pixel images. Adjust the widths of the columns to see all the information if necessary.
InDesign's Links panel with Effective PPI column added

NB: Placed PDFs and Illustrator images cannot show a colour space in the Links panel as they may contain multiple colour spaces. However this GreenLight check will reveal if these placed image types contain any RGB components.

More from Adobe help on Working with Graphics Links in InDesign

Read full article
Links Checks